using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\blog(\w+)\(([^()]+)\)";
string substitution = @"logGeneral(\2, type = ""\L\1"")";
string input = @"logBug(var1, var2)
logInfo(""aa"", var2)
logWarning(""aa"", ""bb"")
logFun(msg1 = ""aa"", msg2 = ""bb"")
logFun(msg1 = var1, msg2 = ""bb"")";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}