#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\blog(\w+)\(([^()]+)\)"
Local $sString = "logBug(var1, var2)" & @CRLF & _
"logInfo("aa", var2)" & @CRLF & _
"logWarning("aa", "bb")" & @CRLF & _
"logFun(msg1 = "aa", msg2 = "bb")" & @CRLF & _
"logFun(msg1 = var1, msg2 = "bb")"
Local $sSubst = "logGeneral(\2, type = "\L\1")"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)