#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\([^)]*\)|\[[^\]]*\]"
Local $sString = "1. The (quick) brown [fox]" & @CRLF & _
"" & @CRLF & _
"2. The (quick) (test) brown [fox] [more] (test) [test][test]" & @CRLF & _
"" & @CRLF & _
"3. The (quick) brown [fox] The (quick) brown [fox] The (quick)" & @CRLF & _
"brown [fox] The (quick) brown [fox]" & @CRLF & _
"" & @CRLF & _
"4. Hopefully, you [don't) have cases like (this]." & @CRLF & _
"" & @CRLF & _
"5. Or this: (nesting (like this), need update to regex)." & @CRLF & _
"" & @CRLF & _
"6. Or heterogeneous mixing: (Test [condition] )" & @CRLF & _
"" & @CRLF & _
"If you have conditions 4, 5, 6. Please update your question!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")