# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\([^)]*\)|\[[^\]]*\]"
test_str = ("1. The (quick) brown [fox]\n\n"
"2. The (quick) (test) brown [fox] [more] (test) [test][test]\n\n"
"3. The (quick) brown [fox] The (quick) brown [fox] The (quick)\n"
"brown [fox] The (quick) brown [fox]\n\n"
"4. Hopefully, you [don't) have cases like (this].\n\n"
"5. Or this: (nesting (like this), need update to regex).\n\n"
"6. Or heterogeneous mixing: (Test [condition] )\n\n"
"If you have conditions 4, 5, 6. Please update your question!")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.