re = /\([^)]*\)|\[[^\]]*\]/
str = '1. The (quick) brown [fox]
2. The (quick) (test) brown [fox] [more] (test) [test][test]
3. The (quick) brown [fox] The (quick) brown [fox] The (quick)
brown [fox] The (quick) brown [fox]
4. Hopefully, you [don\'t) have cases like (this].
5. Or this: (nesting (like this), need update to regex).
6. Or heterogeneous mixing: (Test [condition] )
If you have conditions 4, 5, 6. Please update your question!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end