using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([^)]*\)|\[[^\]]*\]";
string input = @"1. The (quick) brown [fox]
2. The (quick) (test) brown [fox] [more] (test) [test][test]
3. The (quick) brown [fox] The (quick) brown [fox] The (quick)
brown [fox] The (quick) brown [fox]
4. Hopefully, you [don't) have cases like (this].
5. Or this: (nesting (like this), need update to regex).
6. Or heterogeneous mixing: (Test [condition] )
If you have conditions 4, 5, 6. Please update your question!";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}