// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\([^)]*\)|\[[^\]]*\]").unwrap();
let string = "1. The (quick) brown [fox]
2. The (quick) (test) brown [fox] [more] (test) [test][test]
3. The (quick) brown [fox] The (quick) brown [fox] The (quick)
brown [fox] The (quick) brown [fox]
4. Hopefully, you [don't) have cases like (this].
5. Or this: (nesting (like this), need update to regex).
6. Or heterogeneous mixing: (Test [condition] )
If you have conditions 4, 5, 6. Please update your question!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}