import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([^)]*\\)|\\[[^\\]]*\\]";
final String string = "1. The (quick) brown [fox]\n\n"
+ "2. The (quick) (test) brown [fox] [more] (test) [test][test]\n\n"
+ "3. The (quick) brown [fox] The (quick) brown [fox] The (quick)\n"
+ "brown [fox] The (quick) brown [fox]\n\n"
+ "4. Hopefully, you [don't) have cases like (this].\n\n"
+ "5. Or this: (nesting (like this), need update to regex).\n\n"
+ "6. Or heterogeneous mixing: (Test [condition] )\n\n"
+ "If you have conditions 4, 5, 6. Please update your question!";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}