use strict;
my $str = '1. The (quick) brown [fox]
2. The (quick) (test) brown [fox] [more] (test) [test][test]
3. The (quick) brown [fox] The (quick) brown [fox] The (quick)
brown [fox] The (quick) brown [fox]
4. Hopefully, you [don\'t) have cases like (this].
5. Or this: (nesting (like this), need update to regex).
6. Or heterogeneous mixing: (Test [condition] )
If you have conditions 4, 5, 6. Please update your question!';
my $regex = qr/\([^)]*\)|\[[^\]]*\]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}