const regex = /\([^)]*\)|\[[^\]]*\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\([^)]*\\)|\\[[^\\]]*\\]', 'g')
const str = `1. The (quick) brown [fox]
2. The (quick) (test) brown [fox] [more] (test) [test][test]
3. The (quick) brown [fox] The (quick) brown [fox] The (quick)
brown [fox] The (quick) brown [fox]
4. Hopefully, you [don't) have cases like (this].
5. Or this: (nesting (like this), need update to regex).
6. Or heterogeneous mixing: (Test [condition] )
If you have conditions 4, 5, 6. Please update your question!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}