using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(aaa)|(bbb)|(ccc)";
string substitution = @"\2\1\3";
string input = @"aaa
bbb
ccc
aaa
bbb
ccc";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}