$re = '/(aaa)|(bbb)|(ccc)/m';
$str = 'aaa
bbb
ccc
aaa
bbb
ccc';
$subst = "\2\1\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;