re = /(aaa)|(bbb)|(ccc)/m
str = 'aaa
bbb
ccc
aaa
bbb
ccc'
subst = '\\2\\1\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result