// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(aaa)|(bbb)|(ccc)").unwrap();
let string = "aaa
bbb
ccc
aaa
bbb
ccc";
let substitution = "\\2\\1\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}