const regex = /(aaa)|(bbb)|(ccc)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(aaa)|(bbb)|(ccc)', 'gm')
const str = `aaa
bbb
ccc
aaa
bbb
ccc`;
const subst = `\2\1\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);