use strict;
my $str = 'aaa
bbb
ccc
aaa
bbb
ccc';
my $regex = qr/(aaa)|(bbb)|(ccc)/mp;
my $subst = '\\2\\1\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";