package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(aaa)|(bbb)|(ccc)`)
var str = `aaa
bbb
ccc
aaa
bbb
ccc`
var substitution = "\2\1\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}