# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<strong>.*?<\\/strong>(*SKIP)(*FAIL)|\b(boat|car)\b/gokart/gi;t' <<< "The man drove in his car.Then <strong>the man walked to the boat.</strong>"