use strict;
my $str = 'The man drove in his car.Then <strong>the man walked to the boat.</strong>';
my $regex = qr/<strong>.*?<\/strong>(*SKIP)(*FAIL)|\b(boat|car)\b/ip;
my $subst = 'gokart';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";