using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<strong>.*?<\/strong>(*SKIP)(*FAIL)|\b(boat|car)\b";
string substitution = @"gokart";
string input = @"The man drove in his car.Then <strong>the man walked to the boat.</strong>";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}