# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<strong>.*?<\/strong>(*SKIP)(*FAIL)|\b(boat|car)\b"
test_str = "The man drove in his car.Then <strong>the man walked to the boat.</strong>"
subst = "gokart"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.