import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<strong>.*?<\\/strong>(*SKIP)(*FAIL)|\\b(boat|car)\\b";
final String string = "The man drove in his car.Then <strong>the man walked to the boat.</strong>";
final String subst = "gokart";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}