const regex = /<strong>.*?<\/strong>(*SKIP)(*FAIL)|\b(boat|car)\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<strong>.*?<\\\/strong>(*SKIP)(*FAIL)|\\b(boat|car)\\b', 'gi')
const str = `The man drove in his car.Then <strong>the man walked to the boat.</strong>`;
const subst = `gokart`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);