import Foundation
let pattern = #"<strong>.*?<\/strong>(*SKIP)(*FAIL)|\b(boat|car)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"The man drove in his car.Then <strong>the man walked to the boat.</strong>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"gokart"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)