# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*)[.]([0-9]{1})(b|B)([0-9]{1,2})[.](.*)$/$1.0$2b$4$5/gm;t' <<< "abcd.1B21.efg.hi.txt
abcd.1b21.efg.h2i.txt
"