import re
regex = re.compile(r"^(.*)[.]([0-9]{1})(b|B)([0-9]{1,2})[.](.*)$", flags=re.MULTILINE)
test_str = ("abcd.1B21.efg.hi.txt\n"
"abcd.1b21.efg.h2i.txt\n")
subst = "$1.0$2b$4$5"
result = regex.sub(subst, test_str)
if result:
print(result)