re = /^(.*)[.]([0-9]{1})(b|B)([0-9]{1,2})[.](.*)$/m
str = 'abcd.1B21.efg.hi.txt
abcd.1b21.efg.h2i.txt
'
subst = '$1.0$2b$4$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result