import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*)[.]([0-9]{1})(b|B)([0-9]{1,2})[.](.*)$";
final String string = "abcd.1B21.efg.hi.txt\n"
+ "abcd.1b21.efg.h2i.txt\n";
final String subst = "$1.0$2b$4$5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}