package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*)[.]([0-9]{1})(b|B)([0-9]{1,2})[.](.*)$`)
var str = `abcd.1B21.efg.hi.txt
abcd.1b21.efg.h2i.txt
`
var substitution = "$1.0$2b$4$5"
fmt.Println(re.ReplaceAllString(str, substitution))
}