use strict;
my $str = 'abcd.1B21.efg.hi.txt
abcd.1b21.efg.h2i.txt
';
my $regex = qr/^(.*)[.]([0-9]{1})(b|B)([0-9]{1,2})[.](.*)$/mp;
my $subst = '$1.0$2b$4$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";