import Foundation
let pattern = #"^(.*)[.]([0-9]{1})(b|B)([0-9]{1,2})[.](.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abcd.1B21.efg.hi.txt
abcd.1b21.efg.h2i.txt
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.0$2b$4$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)