using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)[.]([0-9]{1})(b|B)([0-9]{1,2})[.](.*)$";
string substitution = @"$1.0$2b$4$5";
string input = @"abcd.1B21.efg.hi.txt
abcd.1b21.efg.h2i.txt
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}