# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[\*(?<group>\w+)\]/<ref group="$group" \/>/g;t' <<< "[*A]
[*refname]
Should not match [*A text] as it is already done in the step before.
"