using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\*(?<group>\w+)\]";
string substitution = @"<ref group=""$group"" />";
string input = @"[*A]
[*refname]
Should not match [*A text] as it is already done in the step before.
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}