$re = '/\[\*(?<group>\w+)\]/';
$str = '[*A]
[*refname]
Should not match [*A text] as it is already done in the step before.
';
$subst = "<ref group=\"$group\" />";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;