re = /\[\*(?<group>\w+)\]/
str = '[*A]
[*refname]
Should not match [*A text] as it is already done in the step before.
'
subst = '<ref group="$group" />'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result