const regex = /\[\*(?<group>\w+)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\*(?<group>\\w+)\\]', 'g')
const str = `[*A]
[*refname]
Should not match [*A text] as it is already done in the step before.
`;
const subst = `<ref group="$group" />`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);