#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[\*(?<group>\w+)\]"
Local $sString = "[*A]" & @CRLF & _
"" & @CRLF & _
"[*refname]" & @CRLF & _
"" & @CRLF & _
"Should not match [*A text] as it is already done in the step before." & @CRLF & _
""
Local $sSubst = "<ref group="$group" />"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)