use strict;
my $str = '[*A]
[*refname]
Should not match [*A text] as it is already done in the step before.
';
my $regex = qr/\[\*(?<group>\w+)\]/p;
my $subst = '<ref group="$group" />';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";