import Foundation
let pattern = #"\[\*(?<group>\w+)\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[*A]
[*refname]
Should not match [*A text] as it is already done in the step before.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<ref group="$group" />"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)