package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\*(?<group>\w+)\]`)
var str = `[*A]
[*refname]
Should not match [*A text] as it is already done in the step before.
`
var substitution = "<ref group="$group" />"
fmt.Println(re.ReplaceAllString(str, substitution))
}