# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^"([^"]*\.exe) *" .*/$1/gm;t' <<< "C:\directory\sub-directory\service.exe ThisTextNeedsRemoving
C:\directory\sub-directory\service.exe -ThisTextNeedsRemoving
C:\directory\sub-directory\service.exe /ThisTextNeedsRemoving
\"C:\direct ory\sub-directory\service.exe\" ThisTextNeedsRemoving
\"C:\direct ory\sub-directory\service.exe\" -ThisTextNeedsRemoving
\"C:\direct ory\sub-directory\service.exe\" /ThisTextNeedsRemoving"