// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^"([^"]*\.exe) *" .*"#).unwrap();
let string = "C:\\directory\\sub-directory\\service.exe ThisTextNeedsRemoving
C:\\directory\\sub-directory\\service.exe -ThisTextNeedsRemoving
C:\\directory\\sub-directory\\service.exe /ThisTextNeedsRemoving
\"C:\\direct ory\\sub-directory\\service.exe\" ThisTextNeedsRemoving
\"C:\\direct ory\\sub-directory\\service.exe\" -ThisTextNeedsRemoving
\"C:\\direct ory\\sub-directory\\service.exe\" /ThisTextNeedsRemoving";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}