const regex = /^"([^"]*\.exe) *" .*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^"([^"]*\\.exe) *" .*', 'gm')
const str = `C:\\directory\\sub-directory\\service.exe ThisTextNeedsRemoving
C:\\directory\\sub-directory\\service.exe -ThisTextNeedsRemoving
C:\\directory\\sub-directory\\service.exe /ThisTextNeedsRemoving
"C:\\direct ory\\sub-directory\\service.exe" ThisTextNeedsRemoving
"C:\\direct ory\\sub-directory\\service.exe" -ThisTextNeedsRemoving
"C:\\direct ory\\sub-directory\\service.exe" /ThisTextNeedsRemoving`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);