using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^""([^""]*\.exe) *"" .*";
string substitution = @"$1";
string input = @"C:\directory\sub-directory\service.exe ThisTextNeedsRemoving
C:\directory\sub-directory\service.exe -ThisTextNeedsRemoving
C:\directory\sub-directory\service.exe /ThisTextNeedsRemoving
""C:\direct ory\sub-directory\service.exe"" ThisTextNeedsRemoving
""C:\direct ory\sub-directory\service.exe"" -ThisTextNeedsRemoving
""C:\direct ory\sub-directory\service.exe"" /ThisTextNeedsRemoving";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}