import Foundation
let pattern = #"^"([^"]*\.exe) *" .*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
C:\directory\sub-directory\service.exe ThisTextNeedsRemoving
C:\directory\sub-directory\service.exe -ThisTextNeedsRemoving
C:\directory\sub-directory\service.exe /ThisTextNeedsRemoving
"C:\direct ory\sub-directory\service.exe" ThisTextNeedsRemoving
"C:\direct ory\sub-directory\service.exe" -ThisTextNeedsRemoving
"C:\direct ory\sub-directory\service.exe" /ThisTextNeedsRemoving
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)