package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^"([^"]*\.exe) *" .*`)
var str = `C:\directory\sub-directory\service.exe ThisTextNeedsRemoving
C:\directory\sub-directory\service.exe -ThisTextNeedsRemoving
C:\directory\sub-directory\service.exe /ThisTextNeedsRemoving
"C:\direct ory\sub-directory\service.exe" ThisTextNeedsRemoving
"C:\direct ory\sub-directory\service.exe" -ThisTextNeedsRemoving
"C:\direct ory\sub-directory\service.exe" /ThisTextNeedsRemoving`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}