use strict;
my $str = 'C:\\directory\\sub-directory\\service.exe ThisTextNeedsRemoving
C:\\directory\\sub-directory\\service.exe -ThisTextNeedsRemoving
C:\\directory\\sub-directory\\service.exe /ThisTextNeedsRemoving
"C:\\direct ory\\sub-directory\\service.exe" ThisTextNeedsRemoving
"C:\\direct ory\\sub-directory\\service.exe" -ThisTextNeedsRemoving
"C:\\direct ory\\sub-directory\\service.exe" /ThisTextNeedsRemoving';
my $regex = qr/^"([^"]*\.exe) *" .*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";