$re = '/^"([^"]*\.exe) *" .*/m';
$str = 'C:\\directory\\sub-directory\\service.exe ThisTextNeedsRemoving
C:\\directory\\sub-directory\\service.exe -ThisTextNeedsRemoving
C:\\directory\\sub-directory\\service.exe /ThisTextNeedsRemoving
"C:\\direct ory\\sub-directory\\service.exe" ThisTextNeedsRemoving
"C:\\direct ory\\sub-directory\\service.exe" -ThisTextNeedsRemoving
"C:\\direct ory\\sub-directory\\service.exe" /ThisTextNeedsRemoving';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;