import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\"([^\"]*\\.exe) *\" .*";
final String string = "C:\\directory\\sub-directory\\service.exe ThisTextNeedsRemoving\n"
+ "C:\\directory\\sub-directory\\service.exe -ThisTextNeedsRemoving\n"
+ "C:\\directory\\sub-directory\\service.exe /ThisTextNeedsRemoving\n"
+ "\"C:\\direct ory\\sub-directory\\service.exe\" ThisTextNeedsRemoving\n"
+ "\"C:\\direct ory\\sub-directory\\service.exe\" -ThisTextNeedsRemoving\n"
+ "\"C:\\direct ory\\sub-directory\\service.exe\" /ThisTextNeedsRemoving";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}